Last Updated: February 25, 2016
·
1.072K
· momoto

Android requires compiler compliance level 5.0 or 6.0

Android requires compiler compliance level 5.0 or 6.0. Found '1.7' instead. Please use Android Tools > Fix Project Properties.

Android SDKが要求するコンパイラ準拠レベルを満たしていないため発生する。必要なJRE(JDKに付属されている)がインストールされていることを確認して、次の手順でEclipseに設定されているJDK準拠レベルを変更する。

  1. "Preferences"から"Java Compiler"のページを開く
  2. "Compiler compliance level" を"1.6"に設定する