yrfyjw

The rmagick gem trouble on linux

If suddenly you get this error

$ gem install rmagick
Building native extensions.  This could take a while...
ERROR:  Error installing rmagick:
    ERROR: Failed to build gem native extension.
Can't install RMagick 2.13.2. Can't find Magick-config

That means the devel package is not installed, so you pick it up on Ubuntu > 12.04

$ sudo apt-get install libmagick++-dev

and you get complete stack

$ dpkg -l | grep imagema
ii  imagemagick
ii  imagemagick-common
ii  libmagic1:i386
ii  libmagick++-dev
......

2 Responses
Add your response

14429
2d8ed84445abecb72733e3e1a4e00709

what if you aren't on ubuntu?? what about freebsd?

over 1 year ago ·
14431
2e1e340e378a26f2c69c6dd418060374

@moracca: unfortunately never test it on BSD like OS

over 1 year ago ·