I've been getting the following error with a few of my Rails 3.2.x apps recently (Rails 4.x is fine):
`require': cannot load such file -- sass/script/node (LoadError)
The issue appears to relate to the version of the
sass gem being used, anything equal to or above 3.3.x causes the error.
In most of my projects it's
bourbon that insists on the new version since version 4.x. To fix the issue I've added the following to my
gem 'bourbon', '~> 3.1.8'
gem 'sass', '~> 3.2.14'
Which resolves the issue. Obviously a better fix would be to update to Rails 4.x. Or for me to set proper versions in the
Gemfile, but I don't use either gem directly.