Joined July 2011
·

Michael Warkentin

Front End Developer at Wave
Front End Developer
Wave
·
Toronto, Ontario
·
·
·

Posted to Homebrew's new feature: Brewfiles over 1 year ago

@pstadler I thought it might be a problem specific to git, but I commented that line out, and the next one blew up the same way. Commented that one out, and the next one blew up..

$ brew bundle
Warning: bash-completion-1.3 already installed
Error: hub-1.10.6 already installed
To install this version, first `brew unlink hub'
Error: Command failed: L4:brew install hub

$ brew bundle
Warning: bash-completion-1.3 already installed
Error: mackup-0.5.2 already installed
To install this version, first `brew unlink mackup'
Error: Command failed: L5:brew install mackup
Posted to Homebrew's new feature: Brewfiles over 1 year ago

This was working great for me.. but something seems to have changed recently, and it's erroring out now:

mwarkentin@Michaels-MacBook-Pro ~  $ brew bundle
Warning: bash-completion-1.3 already installed
Error: git-1.8.5 already installed
To install this version, first `brew unlink git'
Error: Command failed: L3:brew install git

There's a nice tool from Arc90 that also does this: http://lab.arc90.com/2012/04/03/git-sweep/

Achievements
256 Karma
6,617 Total ProTip Views