Joined November 2020
·

kyletheninja

Senior Software Engineer at IHS Markit
·
Southfield
·
·

@andrewjhart @kevinorfas I will never understand how people can say that .forEach is more readable than an actual loop. Languages have keywords for looping for a reason, because they are core concepts that all programming is based on, your IDE will syntax highlight it and everything. List.map .filter and .reduce can all be useful for sure, I find myself using them frequently enough. Foreach as a function is completely pointless though imo. It is also a pain to debug and step through, which to me is the most obvious inferiority it has. For .. of loops are by far the most readable and nicest to type, but they also seem to have pretty bad performance on large collections.

Object Oriented Programming is readable. Maybe my experience with people who get all into the functional programming idea is limited, but those huge blobs of anonymous functions strung about through long spaghetti chains of generic map/filter/forEachs is the complete opposite of readable, to me at least.

Tldr; I completely disagree that functional programming is especially readable or maintainable, at least according to the specific suggestions I hear from people who profess its greatness.

@andrewjhart I will never understand how people can say that .forEach is more readable than an actual loop. Languages have keywords for looping for a reason, because they are core concepts that all programming is based on, your IDE will syntax highlight it and everything. List.map .filter and .reduce can all be useful for sure, I find myself using them frequently enough. Foreach as a function is completely pointless though imo. It is also a pain to debug and step through, which to me is the most obvious inferiority it has. For .. of loops are by far the most readable and nicest to type, but they also seem to have pretty bad performance on large collections.

Object Oriented Programming is readable. Maybe my experience with people who get all into the functional programming idea is limited, but those huge blobs of anonymous functions strung about through generic map/filter/forEachs is the complete opposite of readable, to me at least.

Achievements
1 Karma
0 Total ProTip Views