Where developers come to connect, share, build and be inspired.

16

Getting RMagick working with Mountain Lion

3755 views

So, had to upgrade to Mountain Lion just now due to a client reporting a bug in our application. First thing I noticed is, all my rails projects that use RMagick stopped working. Basically the OS update broke my installation of ImageMagick+RMagick.

Managed to fix it following these steps:

  1. Installed XCode 4.4 and Command Line Tools
  2. Ran this in terminal:

    sudo chown -R <user> /usr/local

    brew update

    brew tap homebrew/dupes

    brew install apple-gcc42

  3. Installed XQuartz 2.7.2 (http://xquartz.macosforge.org/landing)

  4. Fixed any errors reported by brew doctor

  5. Ran this in terminal:

    gem uninstall rmagick

    brew uninstall imagemagick

    brew install --fresh imagemagick

    gem install rmagick

After this, RMagick worked flawlessly again!

Disclaimer: these steps are combination of the indications on these two posts which have been a great help (otherwise I would still be banging my head trying to figure out how to fix this): http://robots.thoughtbot.com/post/27985816073/the-hitchhikers-guide-to-riding-a-mountain-lion http://tektastic.com/2012/07/getting-rmagic-and-friends-to-work-on.html

Comments

  • Blank-mugshot
    sadfuzzy

    The formatting is awful. Not readable at all.

  • Blank-mugshot
    polysign

    sudo chown -R /usr/local

    brew update

    brew tap homebrew/dupes

    brew install apple-gcc42

    • then -

    gem uninstall rmagick

    brew uninstall imagemagick

    brew install --fresh imagemagick

    gem install rmagick

  • Blank-mugshot
    gokuu

    @sadfuzzy Fixed it. @coderwall publishes the post differently than shown on preview

  • Blank-mugshot
    sadfuzzy

    @gokuu thanks!

Add a comment